re = /(?=.*\/{2}.*)[\w?#.,]+|^(?:(?!\/{2}))[\w?#.,]+/m
str = '//comment
code more code code?code //comment
it doesn’t matter if http://doesn´t work..
fasd fdds
asdsd asdasdas hede
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end