#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*error).*?subsite.*"
Local $sString = "https://site.com/51/subsite/special.html" & @CRLF & _
"https://site.com/69/subsite/ok.html" & @CRLF & _
"https://site.com/18/subsite/error.html" & @CRLF & _
"https://site.com/14/pages/special.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")