use strict;
my $str = 'https://site.com/51/subsite/special.html
https://site.com/69/subsite/ok.html
https://site.com/18/subsite/error.html
https://site.com/14/pages/special.html';
my $regex = qr/^(?!.*error).*?subsite.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}