$re = '/^(?!.*error).*?subsite.*/m';
$str = 'https://site.com/51/subsite/special.html
https://site.com/69/subsite/ok.html
https://site.com/18/subsite/error.html
https://site.com/14/pages/special.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);