package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)"[^"]+"(*SKIP)(*FAIL)
|
'[^']+'(*SKIP)(*FAIL)
|
(?|
//(?P<comment>.+)
|
/\*(?P<comment>[\s\S]+?)\*/
)`)
var str = `
/* comments.
is multiline comment*/
String str = " hey, // I'm not a comment "
// one liner comment.
some code here // some comment
some code without comments
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}