$re = '~"[^"]+"(*SKIP)(*FAIL)
|
\'[^\']+\'(*SKIP)(*FAIL)
|
(?|
//(?P<comment>.+)
|
/\*(?P<comment>[\s\S]+?)\*/
)~x';
$str = '
/* comments.
is multiline comment*/
String str = " hey, // I\'m not a comment "
// one liner comment.
some code here // some comment
some code without comments
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);