const regex = new RegExp('"[^"]+"(*SKIP)(*FAIL)
|
\\'[^\\']+\\'(*SKIP)(*FAIL)
|
(?|
//(?P<comment>.+)
|
/\\*(?P<comment>[\\s\\S]+?)\\*/
)', 'g')
const str = `
/* comments.
is multiline comment*/
String str = " hey, // I'm not a comment "
// one liner comment.
some code here // some comment
some code without comments
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}