const regex = /<!--[\s\S]*?-->|<([a-z]+)(?:\s\S+?=(["']|)[\s\S]*?\2)*>((?:[\s\S]*?(?R)?)*)<\/\1>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--[\\s\\S]*?-->|<([a-z]+)(?:\\s\\S+?=(["\']|)[\\s\\S]*?\\2)*>((?:[\\s\\S]*?(?R)?)*)<\\\/\\1>', 'g')
const str = `<span style="font-weight:bold;">this</span> is
<span style="text-
decoration:underline;">my</span> <span
style="font-style:italic;">html</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}