import re
regex = re.compile(r"<!--[\s\S]*?-->|<([a-z]+)(?:\s\S+?=([\"']|)[\s\S]*?\2)*>((?:[\s\S]*?(?R)?)*)<\/\1>")
test_str = ("<span style=\"font-weight:bold;\">this</span> is\n"
"<span style=\"text-\n"
"decoration:underline;\">my</span> <span\n"
"style=\"font-style:italic;\">html</span>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")