$re = '/<!--[\s\S]*?-->|<([a-z]+)(?:\s\S+?=(["\']|)[\s\S]*?\2)*>((?:[\s\S]*?(?R)?)*)<\/\1>/';
$str = '<span style="font-weight:bold;">this</span> is
<span style="text-
decoration:underline;">my</span> <span
style="font-style:italic;">html</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);