package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\s])"([^\s])`)
var str = `this i"s a "test" word i"s"s`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}