re = /([^\s])"([^\s])/m
str = 'this i"s a "test" word i"s"s'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result