$re = '/([^\s])"([^\s])/m';
$str = 'this i"s a "test" word i"s"s';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;