# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\s)"(?!\s)//gm;t' <<< "this i\"s a \"test\" word i\"s\"s"