use strict;
my $str = 'this i"s a "test" word i"s"s';
my $regex = qr/(?<!\s)"(?!\s)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";