re = /(?<!\s)"(?!\s)/m
str = 'this i"s a "test" word i"s"s'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result