package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^;]+)`)
var str = `BLADIEBLA;Dit is het 2de deel
Dit is een string zonder de punt comma`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}