import re
regex = re.compile(r"^([^;]+)", flags=re.MULTILINE)
test_str = ("BLADIEBLA;Dit is het 2de deel\n"
"Dit is een string zonder de punt comma")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")