#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<[^>]*)(\[\s*@?[-_a-zA-Z0-9.$]*%?\s*])(=)(["'])"
Local $sString = "<div [ ngStyle ]="{'max-width.px': i * 2 + 5}"></div>" & @CRLF & _
"<div [ngClass]="[" & @CRLF & _
" 'class-one'," & @CRLF & _
" 'class-two'," & @CRLF & _
" 'class-three'" & @CRLF & _
"]"></div>" & @CRLF & _
"<div [style.right.%]="val"></div>" & @CRLF & _
"<div [@animation.trigger]="val"></div>" & @CRLF & _
"<img [attr.aria-label]="val" />" & @CRLF & _
"<div [my-property]="val"></div>" & @CRLF & _
"<div [my_property]="val"></div>" & @CRLF & _
"<div [myProperty$]="val"></div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/// BELOW SHOULD RETURN NO MATCH " & @CRLF & _
"" & @CRLF & _
"<div [%invalidProperty]="val"></div>" & @CRLF & _
"<div [invalidProperty)="val"></div>" & @CRLF & _
"<div>[my-property]="val"</div>" & @CRLF & _
"<div>" & @CRLF & _
" [my-property]="val"" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")