// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<[^>]*)(\[\s*@?[-_a-zA-Z0-9.$]*%?\s*])(=)(["'])"#).unwrap();
let string = "<div [ ngStyle ]=\"{'max-width.px': i * 2 + 5}\"></div>
<div [ngClass]=\"[
'class-one',
'class-two',
'class-three'
]\"></div>
<div [style.right.%]=\"val\"></div>
<div [@animation.trigger]=\"val\"></div>
<img [attr.aria-label]=\"val\" />
<div [my-property]=\"val\"></div>
<div [my_property]=\"val\"></div>
<div [myProperty$]=\"val\"></div>
/// BELOW SHOULD RETURN NO MATCH
<div [%invalidProperty]=\"val\"></div>
<div [invalidProperty)=\"val\"></div>
<div>[my-property]=\"val\"</div>
<div>
[my-property]=\"val\"
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}