using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[^>]*)(\[\s*@?[-_a-zA-Z0-9.$]*%?\s*])(=)([""'])";
string input = @"<div [ ngStyle ]=""{'max-width.px': i * 2 + 5}""></div>
<div [ngClass]=""[
'class-one',
'class-two',
'class-three'
]""></div>
<div [style.right.%]=""val""></div>
<div [@animation.trigger]=""val""></div>
<img [attr.aria-label]=""val"" />
<div [my-property]=""val""></div>
<div [my_property]=""val""></div>
<div [myProperty$]=""val""></div>
/// BELOW SHOULD RETURN NO MATCH
<div [%invalidProperty]=""val""></div>
<div [invalidProperty)=""val""></div>
<div>[my-property]=""val""</div>
<div>
[my-property]=""val""
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}