package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)(?msi)step start.*?database:dev.*?step end`)
var str = `step start
name:step1
database:dev1
step end
step start
name:step2
database:test1
step end
step start
name:step3
database:dev2
step end
step start
name:step4
database:test2
step end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}