re = /(?msi)step start.*?database:dev.*?step end/m
str = 'step start
name:step1
database:dev1
step end
step start
name:step2
database:test1
step end
step start
name:step3
database:dev2
step end
step start
name:step4
database:test2
step end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end