using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?for\s+(.*?)\s+\((\d+)\s+parent.*\s+(\d+)\s+children.*";
string input = @"
smtpd running for 3+07:04:58 (1 parent / 180 children) (ports: SMTP QMQP)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}