const regex = /.*?for\s+(.*?)\s+\((\d+)\s+parent.*\s+(\d+)\s+children.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?for\\s+(.*?)\\s+\\((\\d+)\\s+parent.*\\s+(\\d+)\\s+children.*', 'g')
const str = `
smtpd running for 3+07:04:58 (1 parent / 180 children) (ports: SMTP QMQP)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}