$re = '/.*?for\s+(.*?)\s+\((\d+)\s+parent.*\s+(\d+)\s+children.*/';
$str = '
smtpd running for 3+07:04:58 (1 parent / 180 children) (ports: SMTP QMQP)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);