package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/(?:www.)?([^.]+)`)
var str = `https://seotoplulugu.blogspot.com.tr/p/seoaraclariyararlilinkler.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}