$re = '/https?:\/\/(?:www.)?([^.]+)/';
$str = 'https://seotoplulugu.blogspot.com.tr/p/seoaraclariyararlilinkler.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);