re = /https?:\/\/(?:www.)?([^.]+)/
str = 'https://seotoplulugu.blogspot.com.tr/p/seoaraclariyararlilinkler.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end