$re = '/.*\bfield\[|\]\[|([^\]]+)/m';
$str = 'a[cat][dog]field[somevalue][anothervalue][other][some][aaa][bbb]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);