re = /.*\bfield\[|\]\[|([^\]]+)/m
str = 'a[cat][dog]field[somevalue][anothervalue][other][some][aaa][bbb]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end