#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@\w+(\(((?:[^()]++|(\g<1>))*)\))?"
Local $sString = "@for($i = 0; $i < 10; $i++)" & @CRLF & _
" {{ $i }}" & @CRLF & _
"@endfor" & @CRLF & _
"" & @CRLF & _
"@if(" & @CRLF & _
" !empty($name)" & @CRLF & _
" && $name == 'Carlos'" & @CRLF & _
")" & @CRLF & _
" Hi Carlos" & @CRLF & _
"@endif" & @CRLF & _
"" & @CRLF & _
"@csrf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")