import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@\\w+(\\(((?:[^()]++|(\\g<1>))*)\\))?";
final String string = "@for($i = 0; $i < 10; $i++)\n"
+ " {{ $i }}\n"
+ "@endfor\n\n"
+ "@if(\n"
+ " !empty($name)\n"
+ " && $name == 'Carlos'\n"
+ ")\n"
+ " Hi Carlos\n"
+ "@endif\n\n"
+ "@csrf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}