$re = '/@\w+(\(((?:[^()]++|(\g<1>))*)\))?/m';
$str = '@for($i = 0; $i < 10; $i++)
{{ $i }}
@endfor
@if(
!empty($name)
&& $name == \'Carlos\'
)
Hi Carlos
@endif
@csrf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);