using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^test\/(?:[A-Z \d]+\/)*$";
string input = @"test/123/
test/123/
test/123/werar/ adfasf/
test/fdfd/";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}