package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^test\/(?:[A-Z \d]+\/)*$`)
var str = `test/123/
test/123/
test/123/werar/ adfasf/
test/fdfd/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}