const regex = /^test\/(?:[A-Z \d]+\/)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^test\\\/(?:[A-Z \\d]+\\\/)*$', 'gmi')
const str = `test/123/
test/123/
test/123/werar/ adfasf/
test/fdfd/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}