# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/внести ([\p{L}\p{N}]+) вклад/зробити $1 внесок/gmu;t' <<< "внести свій вклад
внести значний вклад"