const regex = /внести ([\p{L}\p{N}]+) вклад/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('внести ([\\p{L}\\p{N}]+) вклад', 'gmu')
const str = `внести свій вклад
внести значний вклад`;
const subst = `зробити $1 внесок`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);