$re = '/внести ([\p{L}\p{N}]+) вклад/mu';
$str = 'внести свій вклад
внести значний вклад';
$subst = "зробити $1 внесок";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;