import re
regex = re.compile(r"s:\d+:\"themes\";s:\d+:\"[\w,\s]*(\bbusinessman\b)[\w,\s]*\";", flags=re.IGNORECASE)
test_str = "a:4:{s:5:\"dates\";a:2:{s:7:\"created\";s:27:\"2017-11-03T01:14:56.582259Z\";s:8:\"imported\";s:27:\"2017-11-03T01:14:56.582259Z\";}s:11:\"displayName\";s:12:\"Donald Trump\";s:11:\"description\";s:17:\"Donald John Trump\";s:6:\"themes\";s:10:\"apple, Businessman, Politician\";}"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")