using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""orderEnteredBy\"":\""(?<orderEnteredBy>[^\""]*)\""";
string input = @"availableBalance"":{},""projectedBalance"":{}}},""productSummary"":{""symbol"":""RPACX"",""displayValue"":""RPACX"",""cusip"":""32254T759"",""assetType"":""MUTUAL_FUND"",""description"":""UFACRESCENT FUND N/L"",""settlementDuration"":4,""omnibusProduct"":true},""orderEnteredBy"":""JANEDOE"",""orderUpdatedBy"":""SYS_USER"",""dirtyFSTT"":false,""messagesSummary"":{""messagesCount"":2,""errorsCount"":0,""warningsCount"":0,""infosCount"":0},""assetType"":""MUTUAL_FUND"",""fundServTransactionTypeDetails"":{""cdscValueOverridable"":false,""netAssetValue"":""NAV_OTHER"",""rightsOfAccumulation"":{""additionalHoldings"":0,""manualOverride"":false,""additionalHoldingsValid"":true}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}