# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"orderEnteredBy\":\"(?<orderEnteredBy>[^\"]*)\""
test_str = "availableBalance\":{},\"projectedBalance\":{}}},\"productSummary\":{\"symbol\":\"RPACX\",\"displayValue\":\"RPACX\",\"cusip\":\"32254T759\",\"assetType\":\"MUTUAL_FUND\",\"description\":\"UFACRESCENT FUND N/L\",\"settlementDuration\":4,\"omnibusProduct\":true},\"orderEnteredBy\":\"JANEDOE\",\"orderUpdatedBy\":\"SYS_USER\",\"dirtyFSTT\":false,\"messagesSummary\":{\"messagesCount\":2,\"errorsCount\":0,\"warningsCount\":0,\"infosCount\":0},\"assetType\":\"MUTUAL_FUND\",\"fundServTransactionTypeDetails\":{\"cdscValueOverridable\":false,\"netAssetValue\":\"NAV_OTHER\",\"rightsOfAccumulation\":{\"additionalHoldings\":0,\"manualOverride\":false,\"additionalHoldingsValid\":true}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.