// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"orderEnteredBy\":\"(?<orderEnteredBy>[^\"]*)\""#).unwrap();
let string = "availableBalance\":{},\"projectedBalance\":{}}},\"productSummary\":{\"symbol\":\"RPACX\",\"displayValue\":\"RPACX\",\"cusip\":\"32254T759\",\"assetType\":\"MUTUAL_FUND\",\"description\":\"UFACRESCENT FUND N/L\",\"settlementDuration\":4,\"omnibusProduct\":true},\"orderEnteredBy\":\"JANEDOE\",\"orderUpdatedBy\":\"SYS_USER\",\"dirtyFSTT\":false,\"messagesSummary\":{\"messagesCount\":2,\"errorsCount\":0,\"warningsCount\":0,\"infosCount\":0},\"assetType\":\"MUTUAL_FUND\",\"fundServTransactionTypeDetails\":{\"cdscValueOverridable\":false,\"netAssetValue\":\"NAV_OTHER\",\"rightsOfAccumulation\":{\"additionalHoldings\":0,\"manualOverride\":false,\"additionalHoldingsValid\":true}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}