const regex = /SummerTLE/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SummerTLE', 'i')
const str = `{
"id": "1",
"method": "store",
"params": {
"model": "Impression",
"objects": [
{
"campaignName": "HTML Summer PAID",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.808
},
{
"campaignName": "Nested: Paid Offer 1",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 2",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 3",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.81
}
]
},
"jsonrpc": "2.0"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}