import Foundation
let pattern = #"SummerTLE"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
{
"id": "1",
"method": "store",
"params": {
"model": "Impression",
"objects": [
{
"campaignName": "HTML Summer PAID",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.808
},
{
"campaignName": "Nested: Paid Offer 1",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 2",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 3",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.81
}
]
},
"jsonrpc": "2.0"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}