using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/ByteRange\[\s*(\d+) (\d+) (\d+) (\d+)] /Contents<\s*(\w+)\.*>";
string input = @"/ByteRange[0 49443 61187 6424] /Contents<30820bb506092a864886f70d010702a0820ba630>
/ByteRange[0 49443 61187 6424] /Contents<30820bb506092a864886f70d010702a0820ba630...>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}