import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/ByteRange\\[\\s*(\\d+) (\\d+) (\\d+) (\\d+)] /Contents<\\s*(\\w+)\\.*>";
final String string = "/ByteRange[0 49443 61187 6424] /Contents<30820bb506092a864886f70d010702a0820ba630>\n\n"
+ "/ByteRange[0 49443 61187 6424] /Contents<30820bb506092a864886f70d010702a0820ba630...>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}