use strict;
my $str = '/ByteRange[0 49443 61187 6424] /Contents<30820bb506092a864886f70d010702a0820ba630>
/ByteRange[0 49443 61187 6424] /Contents<30820bb506092a864886f70d010702a0820ba630...>
';
my $regex = qr~/ByteRange\[\s*(\d+) (\d+) (\d+) (\d+)] /Contents<\s*(\w+)\.*>~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}