$re = '/(\b[a-zA-Z]{3,9}\b)/';
$str = 'Michael Franz Tim Mike Stefan Jan Felix Lothar Sebastian Alexander Joachim';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);